Outage Advisory: Campus Wide Network Issues
Incident Report for Penn Carey Law ITS Systems Status
Resolved
ISC has resolved the issue: https://status.isc.upenn.edu/incidents/565695
Posted Feb 20, 2024 - 12:12 EST
Monitoring
Services are returning to regular operation. ISC is monitoring: https://status.isc.upenn.edu/incidents/565695
Posted Feb 20, 2024 - 10:19 EST
Update
We are continuing to investigate this issue.
Posted Feb 20, 2024 - 09:35 EST
Investigating
ISC is investigating a campus-wide network issue that is impacting multiple services including AirPennNet wifi, PennNet, PennFlex Phones, and student printing. More information about the incident including status updates is available at https://status.isc.upenn.edu/
Posted Feb 20, 2024 - 09:33 EST
This incident affected: ITS Systems.