Microsoft 365 Outage

Incident Report for Penn Carey Law ITS Systems Status

Resolved

Microsoft has restored service.
Posted Jan 23, 2026 - 07:07 EST

Update

Microsoft is still working to restore service. You can view status updates here: https://status.cloud.microsoft/
Posted Jan 22, 2026 - 18:08 EST

Monitoring

Per Microsoft's latest status update, Microsoft has stabilized their affected infrastructure and is working to restore service completely. Some users may begin to see a backlog of emails begin to appear in their Outlook mailboxes. Microsoft's next update is expected at 6:00 PM EST.
Posted Jan 22, 2026 - 17:40 EST

Identified

Microsoft is currently investigating an outage affecting Outlook and Microsoft Teams. Other Microsoft 365 services may also be impacted. This issue is widespread and not specific to Penn.

At this time, you may be unable to send or receive email, access Teams messages, or use certain Microsoft 365 apps. We are actively monitoring the situation and will provide updates as more information becomes available.
Posted Jan 22, 2026 - 15:43 EST
This incident affected: ITS Systems.