Firewall Maintenance and Network Outage

Scheduled for Jun 6, 17:00 - 23:00 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 17, 2025 - 11:36 EDT

Scheduled

We will be performing firewall maintenance during this period. There will be an outage to all network services within Law buildings, including wired network devices such as phones, printers, computers and classrooms and wireless network services such as AirPennNet and EduRoam.
Posted Apr 15, 2025 - 17:41 EDT
This scheduled maintenance affects: ITS Systems.