We will be undergoing scheduled maintenance during this time.
Posted Apr 17, 2025 - 11:37 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 17, 2025 - 11:36 EDT
Scheduled
We will be performing network maintenance during this period. There will be a brief outage to all network services within Law buildings, including wired network devices such as phones, printers, computers and classrooms and wireless network services such as AirPennNet and EduRoam.