Outage Advisory: PennBox
Incident Report for Penn Carey Law ITS Systems Status
Resolved
This incident has been resolved.
Posted Dec 15, 2023 - 13:55 EST
Investigating
Box is investigating the issue and has confirmed this issue is impacting all Box Services. Users attempting to use Box may see errors, timeouts, but for the most part services will be completely inaccessible. Additional information will be provided as it becomes available.
Posted Dec 15, 2023 - 10:59 EST
This incident affected: ITS Systems.