Microsoft Azure and Office365 Outage Impacting Multiple Services

Incident Report for Penn Carey Law ITS Systems Status

Resolved

Microsoft has resolved the outage, and service is restored.
Posted Oct 30, 2025 - 10:40 EDT

Identified

Microsoft Azure and Office365 are currently experiencing a widespread outage that is also impacting many downstream systems and applications.

In addition to Microsoft 365 Services, the following services are impacted:
LawKey password reset
Blue course evaluations
Outlook add-ins such as Zoom

We will continue to monitor and share additional information as it becomes available. For additional updates, please visit Microsoft Azure's status page: https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 14:15 EDT
This incident affected: ITS Systems.