Outage Advisory: PennBox
Incident Report for Penn Carey Law ITS Systems Status
Resolved
This incident has been resolved.
Posted Jan 09, 2024 - 16:29 EST
Investigating
Box is investigating an issue with Logins, Uploads, Downloads, All Files page, API calls. Users attempting to use these services may see errors or timeouts. More info at https://box.statuspage.io/
Posted Jan 09, 2024 - 14:29 EST
This incident affected: ITS Systems.