Harvey AI Service Outage

Incident Report for Penn Carey Law ITS Systems Status

Resolved

Harvey AI has been restored.
Posted Sep 10, 2026 - 11:18 EDT

Identified

Harvey AI is currently unavailable. The vendor has identified the cause of the outage and is working to restore access. We will provide updates when they become available.
Posted Sep 10, 2026 - 10:06 EDT
This incident affected: ITS Systems.