Outage Advisory: Law School Network Issues
Incident Report for Penn Carey Law ITS Systems Status
Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 16:25 EDT
Investigating
ITS has confirmed a networking issue in law school buildings. Multiple services are impacted, including AirPennNet wifi, PennNet, PennFlex Phones, and student printing. ISC is investigating, and we will provide updates when they become available.
Posted Mar 26, 2024 - 14:43 EDT
This incident affected: ITS Systems.