Zoom Outage

Incident Report for Penn Carey Law ITS Systems Status

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 17:07 EDT

Investigating

We are currently experiencing a service disruption with Zoom. Users may be unable to start or join Zoom meetings at this time. We are actively monitoring the situation and will provide updates as more information becomes available from Zoom.
Posted Apr 16, 2025 - 15:07 EDT
This incident affected: ITS Systems.