Central Penn Service Outage
Incident Report for Penn Carey Law ITS Systems Status
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 09:50 EDT
Update
Penn services are now operational
Posted Jul 25, 2024 - 09:49 EDT
Update
Many central Penn services are offline due to a data center outage. This includes Banner, Ben Financials, SecureShare, and Penn Portal. Law Services are available with the exception of Student Printing. You can see a complete list and follow the status at https://status.isc.upenn.edu/incidents/622256
Posted Jul 24, 2024 - 13:17 EDT
Investigating
Many central Penn services are offline due to a data center outage. This includes Banner, Ben Financials, SecureShare, and Penn Portal. Law Services are available with the exception of Student Printing. You can see a complete list and follow the status at https://status.isc.upenn.edu/incidents/622256
Posted Jul 24, 2024 - 13:16 EDT
This incident affected: ITS Systems.