Outage Advisory: Campus Wide Network Issues

Incident Report for Penn Carey Law ITS Systems Status

Resolved

This incident has been resolved.
Posted Sep 11, 2025 - 16:34 EDT

Update

ISC is investigating an issue with a core router that is affecting PennNet and Wireless at Penn. They have received reports of network outages at various buildings and services.
Posted Sep 11, 2025 - 15:00 EDT

Update

More information about the incident including status updates is available at https://status.isc.upenn.edu/
Posted Sep 11, 2025 - 14:52 EDT

Update

We are continuing to investigate this issue.
Posted Sep 11, 2025 - 14:44 EDT

Investigating

ISC is investigating a campus-wide network issue that is impacting multiple services including AirPennNet wifi, PennNet, PennFlex Phones, and student printing.
Posted Sep 11, 2025 - 14:43 EDT
This incident affected: ITS Systems.