PennFlex Phone Outage
Incident Report for Penn Carey Law ITS Systems Status
Resolved
This incident has been resolved.
Posted Sep 29, 2023 - 15:47 EDT
Investigating
ISC is reporting a campus wide issue with placing and receiving phone calls from your office handset.

Calls can be made and received on the Webex mobile and desktop applications as a workaround.
View information on using the Webex application: https://www.law.upenn.edu/its/docs/communication/penn-phones.php.

We will share updates as soon as they are available.
Posted Sep 29, 2023 - 09:05 EDT
This incident affected: ITS Systems.