Dashlane - Unexpected Account Notifications and Login Issues

Incident Report for Penn Carey Law ITS Systems Status

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 12:02 EDT

Investigating

Dashlane is currently investigating reports of some users receiving emails that their account has been suspended, as well as login issues affecting users who have reset their master password.

No action needs to be taken at this time. For more information visit: https://status.dashlane.com/
Posted May 31, 2026 - 11:33 EDT